Uncaught TypeError: Cannot read property 'forEach' of null


I am getting the following error in my nexus 3.19.1 running in OKD3.11

Uncaught TypeError: Cannot read property ‘forEach’ of null (https://test-isp-nexus.web.cern.ch/static/rapture/nexus-onboarding-plugin-prod.js?_v=3.19.1-01&_e=OSS:1)

Any idea of what could I be doing wrong?

Similar to Nexus 3.18.1 initial login dont works I guess, but it should be fixed in 3.19

The issue you linked was cause by an ad blocker. Try using a fresh browser (or private mode with all extensions disabled) and try again. We’ve also seen software like McAfee Web Gateway to cause same issue by blocking some of the browser’s POST request.

I have tried in mozilla without any extension and apparently the error persists, also I tried in private mode. anytime I click in sign in or sign out it shows the error

Can you enable developer tools in your browser and inspect the network tab there for any blocked requests?

Sure, I got this error

Right after deploying the APB, I go through setting the password as a new user

And I get this error:

Inspecting the problem, I see:

Request URL: https://test-issp-nexus.web.cern.ch/service/rest/internal/ui/onboarding/change-admin-password
Request Method: PUT
Status Code: 400 Bad Request
Remote Address: [2001:1458:d00:2e::100:4b]:443
Referrer Policy: no-referrer-when-downgrade

Using Chrome:

  • Open the developer tools (cmd+opt+i)
  • Select network tab
  • Clear the log (grey crossed circle icon)
  • Check “Preserve log”
  • In that tab, open (or refresh) NXRM and reproduce the issue
  • Right click the table and “Save all as HAR with content”
  • Share the resulting file with us, if you want to keep it private, please open a ticket at https://issues.sonatype.org/ under “Dev - Nexus Repo (NEXUS)” project

Done, I have created a new ticket.

Thanks for filing the issue. Until we release the fix a workaround would be an admin logging into NXRM and going through the on-boarding wizard and after clicking “Finish” button it should be fine for anyone to log into NXRM. We are sorry for the inconvenience.