Upgrade from 3.15 to 3.19 failed due helm plugin

the helm plugin version is 0.0.8, which is working with 3.15, but after upgrade, nexus will not startup, log says:
org.osgi.framework.BundleException: Unable to resolve
org.sonatype.nexus.plugins.nexus-repository-helm [66](R 66.0): missing
requirement [org.sonatype.nexus.plugins.nexus-repository-helm [66](R
66.0)] osgi.wiring.package;
(&(osgi.wiring.package=jline.internal)(version>=2.14.0)) Unresolved
requirements: [[org.sonatype.nexus.plugins.nexus-repository-helm [66](R
66.0)] osgi.wiring.package;
(&(osgi.wiring.package=jline.internal)(version>=2.14.0))]
at
org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4149)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2119)
at
org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1373)
at
org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)
2019-11-06 16:52:31,869+0800 ERROR [FelixDispatchQueue] *SYSTEM
org.sonatype.nexus.plugins.nexus-repository-helm - FrameworkEvent ERROR
- org.sonatype.nexus.plugins.nexus-repository-helm
org.osgi.framework.BundleException: Unable to resolve
org.sonatype.nexus.plugins.nexus-repository-helm [66](R 66.0): missing
requirement [org.sonatype.nexus.plugins.nexus-repository-helm [66](R
66.0)] osgi.wiring.package;
(&(osgi.wiring.package=jline.internal)(version>=2.14.0)) Unresolved
requirements: [[org.sonatype.nexus.plugins.nexus-repository-helm [66](R
66.0)] osgi.wiring.package;
(&(osgi.wiring.package=jline.internal)(version>=2.14.0))]
at
org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4149)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2119)
at
org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1373)
at
org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
at java.lang.Thread.run(Thread.java:748)

I tried to remove helm plugin from deploy folder, but nexus still failed to start, log says missing recipe: helm-proxy

how can I disable helm plugin? while the old data already contains a helm repository.

I don’t want helm plugin anymore.

Build the plugin in kar format, and drop it into the $installdir/deploy directory.

https://help.sonatype.com/repomanager3/bundle-development/installing-bundles#InstallingBundles-InstallingBundlesInto3.15.0andLater

git clone https://github.com/sonatype-nexus-community/nexus-repository-helm.git
cd nexus-repository-helm

Then edit the pom.xml file, and set the parent version to match your Nexus version:

 <parent>
    <groupId>org.sonatype.nexus.plugins</groupId>    
    <artifactId>nexus-plugins</artifactId> 
    <version>3.19.1-01</version>  
  </parent>   

Then run this to build the kar file:

mvn -PbuildKar clean install

And install it as described in the documentation link above.

1 Like

thanks @rseddon problem fixed

1 Like