Nexus repository doesn't work

Hello community.

I’m new to the Nexus and I’m in the setup phase. I do the installation to Ubuntu 16.04 and I installed an installation as follows:

Installing Java:

$ sudo  apt install openjdk-8-jre-headless -y

Download Nexus:

$ cd /opt 

$ sudo  wget*-unix.tar.gz

$ sudo  tar -zxvf nexus-*-unix.tar.gz

$ sudo  mv /opt/nexus-* /opt/nexus

Create a new user called nexus and grant sudo access to manage nexus services:

$ sudo adduser nexus 

Set no password for nexus user:

$sudo visudo 
nexus   ALL=(ALL)       NOPASSWD: ALL

Change Permission for nexus files:

$ sudo chown -R nexus:nexus /opt/nexus  
$ sudo chown -R nexus:nexus /opt/sonatype-work  

For Nexus as a servive boot time:

$ sudo vim /opt/nexus/bin/nexus.rc  
 run_as_user="nexus" (file shold have only this line)
$ sudo ln -s /opt/nexus/bin/nexus /etc/init.d/nexus

Log in as a nexus user and start service

$ su - nexus  
 $ /etc/init.d/nexus start  

There has been no problem so far. When I ran the last command, I got the “starting Nexus” output. But when I try to connect with my IP address, I cannot go to the website:

I run the following command and listen to port for understand problem:

$ sudo netstat -plnt

But I could not see any service running on port 8081. Can you help me with this issue?

I think you’ll need to take a look at your logs for the service and/or nexus.